• (+84) 8.3868 7885
  • mbtel@daiduongtelecom.com

Bình luận hiển thị từ 1 đến 3 trong tổng số 3

Chủ đề: Vài lệnh cấu hình Switch Cisco .

3 năm trước
#1
Admin
SuperAdmin

CẤU HÌNH SWITCH CISCO123

1.Đặt password cho SW
SW(config)#enable secret cisco
SW(config)#line vty 0 15


SW(config-line)#login
SW(config-line)#pass cisco

2.Tạo VLAN
SW# vlan database
SW(Vlan)# VTP server/client/transparent
SW(Vlan)# VTP domain SDC.COM
SW(Vlan)# Vlan 10 name SDC1 (tạo ra vlan 10 tên là SDC1)
SW(Vlan)# Vlan 20 name SDC2 (tạo ra vlan 20 tên là SDC2)
Tương tự cho các vlan khác.

3.Cấu hình port trunk.
VD bật trunk cho port 1 F0/1
SW(config)# interface f0/1
SW(config-if)# switchport  mode trunk
SW(config-if)# Switchport trunk encapsulation dot1q/isl
Khi làm trên packet tracert 5.1 thi dùng câu lệnh sau.
SW(config-if)# Switchport trunk allow vlan all.

4. Gán port cho vlan
Giả sử port 2,3,4 thuộc vlan 10
Port 5,6,7 thuộc vlan 20
Cách thứ 1:
SW(config)# interface F0/2
SW(config-if)# switchport mode access
SW(config-if)# switchport access vlan 10 (gán port 2 f0/2 vào vlan 10)
Thực hiện tương tự đối với các port còn lại.
Cách thứ 2:
SW(config)#interface range fastEthernet 0/2 - 4
SW(config-if-range)#switchport mode access
SW(config-if-range)#switchport access vlan 10 (Gán port 2,3,4 cho vlan 10)
Còn các vlan khác thực hiện tương tự.

 

Tạo vlan
Switch#config terminal
Switch(config)#vlan 10
Switch(config-vlan)#name ANTOAN
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name VPTRUONG
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name LOPHOC

Kiểm tra cấu hình VLAN
Switch#show vlan

Kích hoạt trunking
Switch(config)#int fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q --> (mặc định trên sw 2950, 2960)
Switch(config-if)#switchport trunk allowed vlan all (mặc định)

Gán các port cho VLAN tương ứng
Switch(config)#interface range fa0/2 – 4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config)# interface range fa0/5 – 7
Switch(config-if)#switchport access vlan 20
Switch(config)# interface range fa0/8 – 10
Switch(config-if)#switchport access vlan 30

Lưu cấu hình
switch#copy running-config startup-config

Cấu hình trên router

Cấu hình sub-interface và trunking
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config)#int fastethernet 0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 172.168.1.14 255.255.255.240
Router(config-subif)#exit
Router(config)#int fastethernet 0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 172.168.2.1 255.255.255.128
Router(config-subif)#exit
Router(config)int fastethernet 0/0.30
Router(config-subif)#encapsulation dot1q 30
Router(config-subif)#ip address 172.168.2.129 255.255.255.128

Lưu cấu hình
Router#copy run start

Cấu hình DHCP Relay Agent
Router(config)#int fastethernet 0/0.20
Router(config-subif)# ip helper-address 172.168.1.1
Router(config)#int fastethernet 0/0.30
Router(config-subif)# ip helper-address 172.168.1.1

Đăng nhập để có thể bình luận !
3 năm trước
#2
Admin
SuperAdmin

test

Đăng nhập để có thể bình luận !
3 năm trước
#3
Admin
SuperAdmin

test trả lời

Đăng nhập để có thể bình luận !
3 năm trước
#4
Admin
SuperAdmin

Thông tin liên tục

Mỗi lệnh đều enter

Cấu hình thiết bị sico

Đăng nhập để có thể bình luận !

Bình luận hiển thị từ 1 đến 3 trong tổng số 3